<!DOCTYPE html>
<html lang="en-US" class="no-js" prefix="og: http://ogp.me/ns#">

<head>
<title>Demolition of Marjory Stoneman Douglas High School delayed by ongoing Broward County death-penalty trial</title>


<!-- Squirrly SEO Plugin 9.2.17, visit: https://plugin.squirrly.co/ -->

<meta name="robots" content="index,follow">
<meta name="description" content="Photo provided by Wikimedia CommonsMarjory Stoneman Douglas High School is a Broward County crime scene today. Fifth in a 6 Part SeriesDemolition of Marjory Stoneman Douglas High School delayed by ongoing Broward County death-penalty trial Could your school district survive a $10.4 million catastrophe? What would" />
<meta name="keywords" content="UCC,The Mainstream,Mainstream,School Shootings,Marjory Stoneman Douglas High School,Marjory Stoneman Douglas" />
<link rel="canonical" href="http://newsite.mainstreamonline.org/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial/" />
<link rel="alternate" type="application/rss+xml" href="http://newsite.mainstreamonline.org/sitemap.xml" />

<meta name="dc.language" content="en-US" />
<meta name="dc.language.iso" content="en_US" />
<meta name="dc.publisher" content="Kamilah Mirza and Kacy Buxton" />
<meta name="dc.title" content="Demolition of Marjory Stoneman Douglas High School delayed by ongoing Broward County death-penalty trial" />
<meta name="dc.description" content="Photo provided by Wikimedia CommonsMarjory Stoneman Douglas High School is a Broward County crime scene today. Fifth in a 6 Part SeriesDemolition of Marjory Stoneman Douglas High School delayed by ongoing Broward County death-penalty trial Could your school district survive a $10.4 million catastrophe? What would" />
<meta name="dc.date.issued" content="2020-02-10" />

<meta property="og:url" content="http://newsite.mainstreamonline.org/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial/" />
<meta property="og:title" content="Demolition of Marjory Stoneman Douglas High School delayed by ongoing" />
<meta property="og:description" content="Photo provided by Wikimedia CommonsMarjory Stoneman Douglas High School is a Broward County crime scene today." />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?fit=1100%2C646" />
<meta property="og:image:width" content="1100" />
<meta property="og:image:height" content="646" />
<meta property="og:site_name" content="The Mainstream" />
<meta property="og:locale" content="en_US" />
<meta property="article:published_time" content="2020-02-10 14:33:11" />
<meta property="article:modified_time" content="2020-02-13 11:40:38" />
<meta property="article:section" content="Campus Life" />
<meta property="article:tag" content="UCC" />
<meta property="article:tag" content="The Mainstream" />
<meta property="article:tag" content="Mainstream" />
<meta property="article:tag" content="School Shootings" />
<meta property="article:tag" content="Marjory Stoneman Douglas High School" />
<meta property="article:tag" content="Marjory Stoneman Douglas" />


<meta property="twitter:url" content="http://newsite.mainstreamonline.org/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial/" />
<meta property="twitter:title" content="Demolition of Marjory Stoneman Douglas High School delayed by ongoing" />
<meta property="twitter:description" content="Photo provided by Wikimedia CommonsMarjory Stoneman Douglas High School is a Broward County crime scene today. Fifth in a 6 Part SeriesDemolition of Marjory Stoneman Douglas High School delayed by ongoing Broward County death-penalty trial Could your school district survive a" />
<meta property="twitter:image" content="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?fit=1100%2C646" />
<meta property="twitter:domain" content="The Mainstream" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:creator" content="@twitter" />
<meta property="twitter:site" content="@twitter" />
<script type="application/ld+json">{"@graph":[{"@context":"https:\/\/schema.org\/","@type":"BreadcrumbList","@id":"http:\/\/newsite.mainstreamonline.org\/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial\/#BreadcrumbList","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"http:\/\/newsite.mainstreamonline.org","name":"The Mainstream |"}},{"@type":"ListItem","position":"2","item":{"@id":"http:\/\/newsite.mainstreamonline.org\/category\/campus-life\/","name":"Campus Life"}},{"@type":"ListItem","position":"3","item":{"@id":"http:\/\/newsite.mainstreamonline.org\/category\/community\/","name":"Community"}},{"@type":"ListItem","position":"4","item":{"@id":"http:\/\/newsite.mainstreamonline.org\/category\/events\/","name":"Events"}},{"@type":"ListItem","position":"5","item":{"@id":"http:\/\/newsite.mainstreamonline.org\/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial\/","name":"Demolition of Marjory Stoneman Douglas High School delayed by ongoing Broward County death-penalty trial"}}]},{"@context":"https:\/\/schema.org\/","@type":"Article","@id":"http:\/\/newsite.mainstreamonline.org\/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial\/#Article","url":"http:\/\/newsite.mainstreamonline.org\/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial\/","name":"Demolition of Marjory Stoneman Douglas High School delayed by ongoing","headline":"Photo provided by Wikimedia CommonsMarjory Stoneman Douglas High School is a Broward County crime scene today.","mainEntityOfPage":{"@type":"WebPage","url":"http:\/\/newsite.mainstreamonline.org\/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial\/"},"datePublished":"2020-02-10T14:33:11+00:00","dateModified":"2020-02-13T11:40:38+00:00","image":{"@type":"ImageObject","url":"https:\/\/i2.wp.com\/newsite.mainstreamonline.org\/wp-content\/uploads\/2020\/02\/MarjoryStonemanDouglas.jpg?fit=1100646","height":"646","width":"1100"},"author":{"@type":"Person","url":"http:\/\/newsite.mainstreamonline.org\/author\/kamilah-mirza-and-kacy-buxton\/","name":"Kamilah Mirza and Kacy Buxton"},"publisher":{"@type":"Organization","url":"http:\/\/newsite.mainstreamonline.org\/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial\/","name":"Kamilah Mirza and Kacy Buxton"},"keywords":"UCC,The Mainstream,Mainstream,School Shootings,Marjory Stoneman Douglas High School,Marjory Stoneman Douglas"}]}</script>
<!-- /Squirrly SEO Plugin -->



<meta charset="UTF-8" />

<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="generator" content="Hoot Ubix Premium 1.8.2" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Mainstream &raquo; Feed" href="http://newsite.mainstreamonline.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Mainstream &raquo; Comments Feed" href="http://newsite.mainstreamonline.org/comments/feed/" />
<link rel="pingback" href="http://newsite.mainstreamonline.org/xmlrpc.php" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/newsite.mainstreamonline.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://newsite.mainstreamonline.org/wp-includes/css/dist/block-library/style.min.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://newsite.mainstreamonline.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='hoot-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400i%2C500%2C600%2C700%2C700i%2C800&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-lightSlider-css'  href='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/css/lightSlider.min.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='hybrid-gallery-css'  href='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/hybrid/css/gallery.min.css?ver=4.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/hybrid/extend/css/font-awesome.min.css?ver=5.0.10' type='text/css' media='all' />
<link rel='stylesheet' id='lightGallery-css'  href='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/css/lightGallery.min.css?ver=1.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='hybridextend-style-css'  href='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/style.min.css?ver=1.8.2' type='text/css' media='all' />
<style id='hybridextend-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='bcd9bfa93c-css'  href='http://newsite.mainstreamonline.org/wp-content/plugins/squirrly-seo/view/assets/css/frontend.min.css?ver=9.2.17' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://newsite.mainstreamonline.org/wp-content/plugins/jetpack/css/jetpack.css?ver=7.9.1' type='text/css' media='all' />
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/js/modernizr.custom.min.js?ver=2.8.3'></script>
<link rel='https://api.w.org/' href='http://newsite.mainstreamonline.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://newsite.mainstreamonline.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://newsite.mainstreamonline.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.5" />
<link rel='shortlink' href='https://wp.me/p7brMa-1nB' />
<link rel="alternate" type="application/json+oembed" href="http://newsite.mainstreamonline.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fnewsite.mainstreamonline.org%2Fdemolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://newsite.mainstreamonline.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fnewsite.mainstreamonline.org%2Fdemolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://i1.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2018/08/cropped-Hawk_Icon.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2018/08/cropped-Hawk_Icon.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2018/08/cropped-Hawk_Icon.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2018/08/cropped-Hawk_Icon.jpg?fit=270%2C270" />
</head>

<body class="wordpress ltr en en-us parent-theme y2020 m02 d22 h16 saturday logged-out singular singular-post singular-post-5307 post-template-default" dir="ltr" itemscope="itemscope" itemtype="https://schema.org/Blog">

	
	<a href="#main" class="screen-reader-text">Skip to content</a>

	<div id="page-wrapper" class=" hgrid site-boxed page-wrapper sitewrap-full-width sidebars0 hoot-cf7-style hoot-mapp-style hoot-jetpack-style">

			<div id="topbar" class=" topbar  inline-nav hgrid-stretch">
		<div class="hgrid">
			<div class="hgrid-span-12">

				<div class="topbar-inner table">
					
											<div id="topbar-right" class="table-cell-mid">
							<div class="topbar-right-inner">
								<section id="search-3" class="widget widget_search"><h3 class="widget-title">Search</h3><div class="searchbody"><form method="get" class="searchform" action="http://newsite.mainstreamonline.org/" ><label for="s" class="screen-reader-text">Search</label><i class="fas fa-search"></i><input type="text" class="searchtext" name="s" placeholder="Type Search Term &hellip;" value="" /><input type="submit" class="submit forcehide" name="submit" value="Search" /></form></div><!-- /searchbody --></section>							</div>
						</div>
									</div>

			</div>
		</div>
	</div>
	
		<header id="header" class="site-header header-layout-primary-menu header-layout-secondary-top tablemenu hybridextend-sticky-header" role="banner" itemscope="itemscope" itemtype="https://schema.org/WPHeader">

					<div id="header-supplementary" class=" header-part header-supplementary-top header-supplementary-center">
			<div class="hgrid">
				<div class="hgrid-span-12">
									</div>
			</div>
		</div>
		
			<div id="header-primary" class=" header-part header-primary-menu">
				<div class="hgrid">
					<div class="table hgrid-span-12">
							<div id="branding" class="site-branding branding table-cell-mid">
		<div id="site-logo" class="site-logo-custom">
			<div id="site-logo-custom"><div id="site-title" class="site-title" itemprop="headline"><a href="http://newsite.mainstreamonline.org" rel="home"><span class="site-title-line site-title-line1">The Mainstream</span></a></div></div><!--logotext-->		</div>
	</div><!-- #branding -->
	<div id="header-aside" class=" header-aside table-cell-mid  header-aside-menu">	<div class="screen-reader-text">Primary Navigation Menu</div>
	<nav id="menu-primary" class="menu menu-primary nav-menu mobilemenu-inline mobilesubmenu-click scrollpointscontainer" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="menu-toggle"><span class="menu-toggle-text">Menu</span><i class="fas fa-bars"></i></div>

		<ul id="menu-primary-items" class="menu-items sf-menu menu"><li id="menu-item-26" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-26"><a href="http://newsite.mainstreamonline.org/"><span class="menu-title">Home</span></a></li>
<li id="menu-item-221" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-221"><a href="http://newsite.mainstreamonline.org/category/campus-life/"><span class="menu-title">Campus Life</span></a></li>
<li id="menu-item-223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-223"><a href="http://newsite.mainstreamonline.org/category/health/"><span class="menu-title">Health</span></a></li>
<li id="menu-item-225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-225"><a href="http://newsite.mainstreamonline.org/category/sports/"><span class="menu-title">Sports</span></a></li>
<li id="menu-item-226" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-226"><a href="http://newsite.mainstreamonline.org/category/events/"><span class="menu-title">Events</span></a></li>
<li id="menu-item-222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-222"><a href="http://newsite.mainstreamonline.org/category/columns/"><span class="menu-title">Columns</span></a></li>
</ul>
	</nav><!-- #menu-primary -->
	</div>					</div>
				</div>
			</div>

			
		</header><!-- #header -->

		
		<div id="main" class=" main">
			

				<div id="loop-meta" class=" loop-meta-wrap pageheader-bg-stretch">
					<div class="hgrid">

						<div class=" loop-meta  hgrid-span-12" itemscope="itemscope" itemtype="https://schema.org/WebPageElement">
							<div class="entry-header">

																<h1 class=" loop-title" itemprop="headline">Demolition of Marjory Stoneman Douglas High School  delayed by ongoing Broward County death-penalty trial</h1>

								<div class=" loop-description" itemprop="text"><div class="entry-byline"> <div class="entry-byline-block entry-byline-author"> <span class="entry-byline-label">By:</span> <span class="entry-author" itemprop="author" itemscope="itemscope" itemtype="https://schema.org/Person"><a href="http://newsite.mainstreamonline.org/author/kamilah-mirza-and-kacy-buxton/" title="Posts by Kamilah Mirza and Kacy Buxton" rel="author" class="url fn n" itemprop="url"><span itemprop="name">Kamilah Mirza and Kacy Buxton</span></a></span> </div> <div class="entry-byline-block entry-byline-date"> <span class="entry-byline-label">On:</span> <time class="entry-published updated" datetime="2020-02-10T14:33:11-08:00" itemprop="datePublished" title="Monday, February 10, 2020, 2:33 pm">February 10, 2020</time> </div> <div class="entry-byline-block entry-byline-cats"> <span class="entry-byline-label">In:</span> <a href="http://newsite.mainstreamonline.org/category/campus-life/" rel="category tag">Campus Life</a>, <a href="http://newsite.mainstreamonline.org/category/community/" rel="category tag">Community</a>, <a href="http://newsite.mainstreamonline.org/category/events/" rel="category tag">Events</a> </div><span class="entry-publisher" itemprop="publisher" itemscope="itemscope" itemtype="https://schema.org/Organization"><meta itemprop="name" content="The Mainstream"><span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""><meta itemprop="width" content=""><meta itemprop="height" content=""></span></span></div><!-- .entry-byline --></div><!-- .loop-description -->
							</div><!-- .entry-header -->
						</div><!-- .loop-meta -->

					</div>
				</div>

			
<div class="hgrid main-content-grid">

	
	<main id="content" class="content  hgrid-span-12 no-sidebar layout-full-width " role="main">

		
			<div id="content-wrap">

				<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject" class="entry-featured-img-wrap"><meta itemprop="url" content="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?fit=1100%2C646"><meta itemprop="width" content="1100"><meta itemprop="height" content="646"><img width="1100" height="646" src="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?fit=1100%2C646" class="attachment-full  entry-content-featured-img wp-post-image" alt="" itemscope="" srcset="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?w=1100 1100w, https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?resize=150%2C88 150w, https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?resize=300%2C176 300w, https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?resize=500%2C294 500w, https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?resize=425%2C250 425w" sizes="(max-width: 1100px) 100vw, 1100px" data-attachment-id="5308" data-permalink="http://newsite.mainstreamonline.org/demolition-of-marjory-stoneman-douglas-high-school-delayed-by-ongoing-broward-county-death-penalty-trial/marjorystonemandouglas/" data-orig-file="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?fit=1100%2C646" data-orig-size="1100,646" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MarjoryStonemanDouglas" data-image-description="" data-medium-file="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?fit=300%2C176" data-large-file="https://i2.wp.com/newsite.mainstreamonline.org/wp-content/uploads/2020/02/MarjoryStonemanDouglas.jpg?fit=500%2C294" itemprop="image" /></div>
	<article id="post-5307" class="entry author-kamilah-mirza-and-kacy-buxton post-5307 post type-post status-publish format-standard has-post-thumbnail category-campus-life category-community category-events" itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost">

		<div class="entry-content" itemprop="articleBody">

			<div class="entry-the-content">
				
<p style="font-size:11px;text-align:right"><em>Photo provided by Wikimedia Commons</em><br>Marjory Stoneman Douglas High School is a Broward County crime scene today.</p>



<p class="has-medium-font-size">Fifth in a 6 Part Series<br><strong>Demolition of Marjory Stoneman Douglas High School  delayed by ongoing Broward County death-penalty trial </strong></p>



<p>Could your school
district survive a $10.4 million catastrophe? What would you do when
potentially 800 people’s lives were put in immediate risk at your school? How
would you as an administrator, staff member, student, parent or community
member survive? </p>



<p>Broward County, Florida
school superintendent Robert Runcie had to face these questions.</p>



<p>On Feb. 14, 2018, the
anniversary of Northern Illinois University’s school shooting, Marjory Stoneman
Douglas High School in Parkland, Florida succumbed to one of the deadliest mass
shootings in U.S. history. After the shooter entered the school’s Building 12,
he took the lives of 14 students and three staff members, additionally injuring
17. Up to 800 people were in the building at the time. Superintendent Runcie’s
ordeal began immediately after this shooting.</p>



<p>The media alternatively
villainized and celebrated Runcie as parents of Parkland students began
complaining that they wanted the building torn down (Building 12 had cost $10.4
million to build). As his district’s students marched, they eventually
convinced Florida Gov. Rick Scott to sign the Marjory Stoneman Douglas High
School Public Safety Act, according to the school’s initial report. Runcie’s
school and his students became household names.</p>



<p>Part of the Safety Act
required the creation of the Marjory Stoneman Douglas High School Safety
Commission. The commission specifically analyzes information from the Marjory
Stoneman Douglas High School shooting, as well as other places of education
that have experienced the same tragedy, to help better understand the impact of
violence and to prevent future acts. </p>



<p>Just two weeks after
the Marjory Stoneman Douglas school shooting, students in Runcie’s district
returned to classes in portable buildings brought onto the campus while at the
same time community members pressured to remove Building 12 because of how it
was going to impact students and staff members seeing it on a daily basis.
Meanwhile, the three-story Building 12 was still being swept as a crime scene. </p>



<p>Students, staff members
and community members are still seeing Building 12 on a daily basis almost two
years later. “The building remains in custody of the Broward County State
Attorney’s Office as evidence in the upcoming trial,” Keyla Concepcion, manager
of media and community relations, said in an email interview.&nbsp; As it is a crime scene, it must be held as
such till the end of the shooter’s death-penalty trial, which has been delayed
until this summer. Building 12 will stand until it is no longer needed for law
enforcement.</p>



<p>Marjory Stoneman
Douglas High School is now known for its association with the Feb. 14, 2018 tragedy.
Before the shooting, the school name was known for honoring an important figure
in the Parkland community: journalist, environmentalist and Presidential Medal
of Freedom award winner, Marjory Stoneman Douglas. Stoneman, born in 1890,
founded “Friends of the Everglades” and advocated for racial equality and
women’s rights, according to A&amp;E Television. </p>



<p>Buildings 12 and 13 had
been added in 2009 for the high school which serves over 3,000 students in 14
buildings on 45 acres of land (the school opened in 1990 as Broward County’s
first public high school). The campus that the shooter entered included
entrance doors placed directly into stairwells, allowing easy access from the
outside to all three floors. Classroom doors required locking from the outside.
That meant teachers had to exit their classroom during the shooting and use a
key to lock the door from the hallway to keep their students safe.&nbsp; The metal classroom doors feature an 8 inch
wide pane of glass. The interior walls are constructed with drywall which
bullets can pierce through. </p>



<p>Once the Florida state
attorney’s office releases the 11-year-old Building 12, it is slated to be torn
down and replaced by a new 44,480 square feet, two story, $18 million building
to be designed by Zyscovich Architects and constructed by James B. Pirtle
Construction.</p>



<p>It will have an
improved intercom system and controlled access points. Motion sensored LED
lights, for both the interior and exterior, will be installed for improved,
more efficient lighting of the 30 classrooms. Other energy and storm
improvements are being planned as well. </p>



<p>Umpqua Community
College’s purchasing manager, Jules DeGiulio, was involved in a similar capital
project when UCC’s Snyder Hall shooting required building a new facility.
“People were in recovery mode, and they needed time to help each other.
But, the college still needed to continue to operate,” DeGiulio said. DeGiulio
explained that the only way UCC was able to survive was an onslaught of
experienced volunteers, 24/7, some from outside of the state, some who stayed
for months. The amount of work in an emergency capital project is staggering,
he explained.&nbsp; </p>



<p>Though much of that work still remains, the new Marjory
Stoneman Douglas building has had the foundation laid and the interior and
exterior columns put into place.&nbsp;
Concrete has been poured for the elevator shaft and egress stair, also
the first and second floor slabs and roof slabs. Connecting walkway columns and
beams, underground utilities, and roof tie beams and parapet have all been
built, as well as other work.</p>



<p>According to the Broward County Education Foundation, the
Marjory Stoneman Douglas Victims’ Fund will be allocating funds in July:&nbsp; $400,000 to families of the 17 victims, $1.63
million for the 18 injured individuals, $2,500 for the 450 students who were in
the building at the time of the shooting and $1,000 for the 1,048 students who
were on campus during the time of the incident.</p>



<p>After the tragedy of a school shooting event has passed,
the side effects on mental health have a ripple effect in the minds of
survivors, many now having post-traumatic stress disorder.The urgency for how
this is impacting students is felt deeply in the Parkland community. One week
after the school shooting, a 16-year-old student survivor died by suicide, a
year later another 19-year-old student survivor died by suicide. </p>



<p>The U.S. Army posthumously honored three of the students
whose lives were lost while defending others at the time of the shooting with
Medals of Heroism, which is the highest medal for Junior Reserve Officers’
Training Corps cadets.&nbsp; One of the
students, Peter Wang, a member of the JROTC, was given a posthumous admission
to the U.S. Military Academy at West Point for the Class of 2025. </p>



<p>As of now,&nbsp; $1 million
has been set aside for a future memorial. However, in January 2019, student
Victoria Gonzales and teacher Ronit Roeven came together and started “Project
Love.” Through the project a memorial garden was created in honor of the
students who lost their lives. The garden can be found on the northeast side of
the high school, supplied by donations from members of the community.</p>



<p><em>Contact me at: </em><br><em>UCCMainstream@yahoo.com</em></p>



<p>For part 6 in the series click <a href="http://newsite.mainstreamonline.org/virginia-tech-transforms-shooting-building-into-center-for-peace-studies/">here</a></p>
			</div>
					</div><!-- .entry-content -->

		<div class="screen-reader-text" itemprop="datePublished" itemtype="https://schema.org/Date">2020-02-10</div>

		
	</article><!-- .entry -->


			</div><!-- #content-wrap -->

			
	<div class="loop-nav">
		<div class="prev">Previous Post: <a href="http://newsite.mainstreamonline.org/west-nickel-mines-amish-school-unique-story-of-forgiveness-and-healing/" rel="prev">West Nickel Mines Amish School: unique story of forgiveness and healing</a></div>		<div class="next">Next Post: <a href="http://newsite.mainstreamonline.org/virginia-tech-transforms-shooting-building-into-center-for-peace-studies/" rel="next">Virginia Tech transforms shooting building into Center for Peace Studies</a></div>	</div><!-- .loop-nav -->


	</main><!-- #content -->

	
	
</div><!-- .hgrid -->

		</div><!-- #main -->

		
		
<footer id="footer" class="site-footer  footer hgrid-stretch footer-highlight-typo " role="contentinfo" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
	<div class="hgrid">
					<div class="hgrid-span-4 footer-column">
				<section id="archives-3" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='http://newsite.mainstreamonline.org/2020/02/'> February 2020 </option>
	<option value='http://newsite.mainstreamonline.org/2020/01/'> January 2020 </option>
	<option value='http://newsite.mainstreamonline.org/2019/11/'> November 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2019/10/'> October 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2019/06/'> June 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2019/05/'> May 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2019/04/'> April 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2019/03/'> March 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2019/02/'> February 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2019/01/'> January 2019 </option>
	<option value='http://newsite.mainstreamonline.org/2018/12/'> December 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/11/'> November 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/10/'> October 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/06/'> June 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/05/'> May 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/04/'> April 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/03/'> March 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/02/'> February 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2018/01/'> January 2018 </option>
	<option value='http://newsite.mainstreamonline.org/2017/12/'> December 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2017/11/'> November 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2017/10/'> October 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2017/06/'> June 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2017/05/'> May 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2017/04/'> April 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2017/03/'> March 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2017/02/'> February 2017 </option>
	<option value='http://newsite.mainstreamonline.org/2016/11/'> November 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/10/'> October 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/09/'> September 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/06/'> June 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/05/'> May 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/04/'> April 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/03/'> March 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/02/'> February 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2016/01/'> January 2016 </option>
	<option value='http://newsite.mainstreamonline.org/2015/12/'> December 2015 </option>
	<option value='http://newsite.mainstreamonline.org/2015/11/'> November 2015 </option>
	<option value='http://newsite.mainstreamonline.org/2012/12/'> December 2012 </option>
	<option value='http://newsite.mainstreamonline.org/2010/11/'> November 2010 </option>

		</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</section>			</div>
					<div class="hgrid-span-4 footer-column">
				<section id="text-3" class="widget widget_text"><h3 class="widget-title">Mission Statement:</h3>			<div class="textwidget"><p>The Mainstream is a designated student forum written to promote the activities, events, and interests of UCC. Its primary focus is on hard news relating to campus events or personnel, especially as students are affected, but features, art work and poetry may be accepted. Any opinions or art presented in The Mainstream do not represent the viewpoint of this newspaper or UCC.</p></div>
		</section>			</div>
					<div class="hgrid-span-4 footer-column">
				<section id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">Links</h3><div class="menu-links-container"><ul id="menu-links" class="menu"><li id="menu-item-2083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2083"><a href="http://newsite.mainstreamonline.org/about/"><span class="menu-title">About</span></a></li>
<li id="menu-item-1895" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1895"><a href="http://newsite.mainstreamonline.org/contact-us/"><span class="menu-title">Contact</span></a></li>
<li id="menu-item-1896" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1896"><a href="http://newsite.mainstreamonline.org/ad-prices/"><span class="menu-title">Ad Prices</span></a></li>
</ul></div></section>			</div>
			</div>
</footer><!-- #footer -->


			<div id="post-footer" class="post-footer  hgrid-stretch footer-highlight-typo linkstyle">
		<div class="hgrid">
			<div class="hgrid-span-12">
				<p class="credit small">
					 Designed using <a class="wp-theme-link" href="https://wordpress.org/themes/hoot-ubix/" title="Hoot Ubix Premium WordPress Theme">Hoot Ubix Premium</a>. Powered by <a class="wp-link" href="https://wordpress.org">WordPress</a>.				</p><!-- .credit -->
			</div>
		</div>
	</div>

	</div><!-- #page-wrapper -->

		<div style="display:none">
	</div>
<a href="#page-wrapper" class="fixed-goto-top waypoints-goto-top "><i class="fas fa-chevron-up"></i></a><script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/newsite.mainstreamonline.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.4'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202008'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.2.5'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/js/jquery.superfish.min.js?ver=1.7.5'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/js/jquery.lightSlider.min.js?ver=1.1.1'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/js/jquery.fitvids.min.js?ver=1.1'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/js/jquery.parallax.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var hootData = {"lightbox":"enable","lightboxWpGal":"disable","lightGallery":"enable","isotope":"enable"};
/* ]]> */
</script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/js/hoot.theme.min.js?ver=1.8.2'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/js/lightGallery.min.js?ver=1.1.4'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/js/jquery.circliful.min.js?ver=20160309'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/hybrid/extend/js/jquery.waypoints.min.js?ver=4.0.1'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/hybrid/extend/js/sticky.min.js?ver=4.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var hybridExtendData = {"customScrollerPadding":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/hybrid/extend/js/scrollpoints.min.js?ver=2.2.6'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/hybrid/extend/js/scroller.min.js?ver=2.2.6'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-content/themes/hoot-ubix-premium/premium/js/hoot.theme.premium.min.js?ver=1.8.2'></script>
<script type='text/javascript' src='http://newsite.mainstreamonline.org/wp-includes/js/wp-embed.min.js?ver=5.2.5'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202008.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'106162734',post:'5307',tz:'-8',srv:'newsite.mainstreamonline.org'} ]);
	_stq.push([ 'clickTrackerInit', '106162734', '5307' ]);
</script>

</body>
</html>